GPD User Community Support Forum

Backlight flickering

0.27, but frankly I think this should be some sort of hardware issue that got triggered accidentally by some part of my hackintosh process, cuz otherwise it shouldn’t just go away when I left it alone for some time…

1 Like

II’m still on 0.24 bios simply because Kendyz advises that 0.25 was not public yet?
Clearly it was included in the firmware pack.

Not sure how @PeterCxy has 0.27 can only assume he is working closely with gpd team.

Also I have no idea what the differences are with 0.24 / 0.25 / 0.26 or 0.27.

My issue of flicker still occurs intermittently as @joshwiththegoodhair mentions when the screen enters sleep (not suspend or hibernate) and then is resumed. But I’m more concerned with my screen not resuming from sleep than the slight flicker as if I wait long enough or power down for an hour or two the flicker is gone.

I’m on gpd p2 max specific Ubuntu mate 19.10 iso.
For the record I only have Ubuntu Mate and no other windows or hackintosh partition.

Yesterday, the screen didn’t turn back on after screensaver. I let the machine powered on and did nothing, then when moving the mouse 2-3 hours later, the screen came back to life, without flicker. I’m still on 0.24 + debian buster.

I don’t know, I just went to their website and saw there was something newer than 0.24, I remember it’s 0.27 somehow…

The specific GPD message regarding the 0.27 firmware is “This is the 0.27 version BIOS of P2 Max that solves the problems of scratch screen,two different screens,half screen,some vertical lines on the screen,if you don’t have these issues,please don’t upgrade it.” I’m unsure of this does anything for flicking screens?

I’m not 100% positive, but I think that in addition to this issue happening after a suspend -> resume, I also think this might be related to either a USB-C hub (with PD/power delivery) OR using a power adapter that’s over 12V (like 15V or 20V). Can anyone (@admin) who has had this issue verify this is (or isn’t) the case for them, and I’ll research further.

1 Like

Happened to me today. Windows 10 Pro x64 1909 with December update. The system was closed and powered on and plugged in to a 5v 2.4A USB adapter. Picked it up and opened the screen and the flickering looks almost like a slow screen refresh rate to me then a backlight as I only see it on colors and not white.

BIOS 0.24 and occurs in BIOS/UEFI firmware settings as well.

I was using the GPD provided USB source when it happened. The p2max has been running pretty much 24/7 and I didn’t update the bios, yet it didn’t happen again. I don’t have more clues.

But I thought more about it and wondered whether I originally correctly identified the symptoms. I said it was the backlight, but it may be the lcd itself flickering, because indeed, it was more visible on colors/darker zones than on white/bright zones.

Well, I shutdown yesterday and powered back on and it still appears to be happening. How long did it take to stop for you and did you leave it on or off?

A few hours later it was invisible, the machine was kept on but the display was off (screensaving).

@joshwiththegoodhair (I’ve only ever used the USBC cable and the Genuine adapter that shipped with the GPD from memory I cannot remember what that was but the max Volts/Amperage was posted on this forum.)

Mine still intermittently flickers from time to time usually if left to idle to screensaver for extended period and then I resume from. My Bios is still 0.24. Recently I noticed that even if I shut it down and left it powered off for 5 minutes on starting up it was still flickering eventually it either stops or my eyes adjust to it and I don’t notice it as much.

Drastically reduced by this evening but still slightly there. Hopefully it is something GPD can fix through either a display specific driver or firmware but at least it feels usable again, at first it was so bad I couldn’t stand to look at it

I just had the same issue.
Laptop was open and running for ah hour or so with micro-hdmi to HDMI screen projection using just the external screen, laptop was plugged into a equivalently rated power supply via USB-C.

Then I locked the laptop when I walked away for a few minutes and upon returning after waking the laptop it was using the laptop screen and the backlight was flickering.
Turning down the backlight to it’s lowest setting confirms it’s the backlight and not the graphics driver.
In the past I’ve had other laptops have the same problem caused by it rapidly swapping screen refresh rates, but the p2max only has a 60htz refresh rate in Windows 10.

I have the same problem on my gpd p2max:

  • screen goes to sleep due to power saving settings (not full suspend, just the screen); laptop temperature is cool as it is basically idling
  • trying to wake the screen up does not work, after moving mouse or typing the screen stays black, but the laptop is otherwise responsive
  • put it to sleep, wake it and screen is back, but flickering
  • turning it off or going to another OS does not help
  • can’t notice any flickering on the lowest backlight, but the very next level already shows flickering
    It has happened three times. The first two times it quickly went away, this third time (and the reason I ended up in this forum) is not going away so soon. After 1 hour it feels like the flickering is not as bad, but will have to wait longer to see if it finally goes away.

I can see the flickering in the BIOS screen as well.

My main OS is Ubuntu Eoan (19.10) and I have been through a few kernel updates.

Changing the kernel (or even the OS) does not help at all, so it seems like it is a hardware problem triggered by the screen going to sleep somehow.

Does this problem happen when only using Windows? I’m curious if this is a linux-only thing?

Obviously, if this happens in linux, it persists if you restart into Windows, but if someone is only using Windows, does this problem ever occur? If it’s only happening in linux, there might be some hope with some weird DPMS settings, but if it’s happening in Windows as well, it’s a hardware issue that has to be fixed.

I only really use Linux on it. Windows is there, but I rarely boot on it.

Hopefully someone else who is using Windows more often might be able to tell if the problem ever occurs there - but it does take a while to happen, I have been running it for more than 4 months straight and I only seen it happen 3 times.

Edit: This did not work and the problem came back after a couple days. :frowning:

So, being stuck at home for COVID yesterday, I spent a little time trying to resolve this issue, and think I may have found a solution. I updated the kernel and that seemed to make this issue happen every single restart - which was annoying, but created a good test scenario.

First - to answer my own previous question, Windows can cause the issue when power management turns off the display, so it is definitely hardware related. I also went into linux and tried a couple different options in terms of how power management turns off the display - xscreensaver, xfce/xflock4, gnome-screensaver, etc. This problem happened in each scenario. But one thing I noticed is that I could occasionally see part of the screen that should have been showing (for a quick second) before the screen turned black, but was still powered on. This behavior is very similar to when Windows does updates and when the Pocket restarts, the BIOS and Windows loading screen has similar weird behavior. It’s almost as if, on a lower level, the display resolution/mode wasn’t syncing or being set properly.

That led me to believe that maybe there was something in the BIOS that could potentially fix. I switched a couple options which seems to have resolved this:

  • Boot > Fast Boot > Enabled
  • Boot > Fast Boot > “VGA Support” = Auto (was “EFI Driver”)
  • Boot > Quiet Boot > Disabled

Now, when I boot, the EFI screen is giant and ugly, but so far, I haven’t been able to recreate the weird suspend issue. My thought is the second “VGA Support” option is disabling EFI resolutions (or something similar) which is the cause of the problem.

Again, I’ve only tested this “good” behavior for a day, but I have spent many restarts and scenarios trying to recreate the problem and haven’t been able to. I thought I would share to see if anyone else wanted to give it a try and report back?

Edit: Almost two weeks later and this is still working. Whenever I need to reboot, I power off the P2 Max, disconnect the power adapter, power it back on, then reconnect the power adapter. I’ve yet to have the flickering issue again (although this “solution” is a PITA).

A new week and new tests.

For me, if this flickering/lock issue is going to happen, it almost always happens upon first lock. I’ve been using that as a test scenario to test some power cycling scenarios.

  • (power adapter disconnected) power off > power on > connect power adapter after Xorg is loaded - no issues with unlocking or flickering
  • (power adapter connected) power off > power on - occasional lock issues (25% of the time)
  • (power adapter disconnected) reboot/restart - good number of lock issues (40% of the time)
  • (power adapter connected) reboot/restart - this seems to cause the most issues for me; almost every time (80% of the time); this is also the scenario I typically use when rebooting

So, for now, I’m going to try disconnecting the power adapter, powering off, then back on, then connect power again. I’ll report back.

Hello,

I booted my P2 Max up today and left it running with the screen closed while charging. When I opened it back up I had a flickering screen. It’s pretty bad. Hard to look at for more than a couple of seconds.

@joshwiththegoodhair:

I’ve tried what you suggested with no luck. I also tried updating my BIOS to the 1.27 version. This did not help.

I’ve had my P2 Max for less than six months, and I’m bummed out. Does anyone know if I’m out of luck, or will GPD work with me?

I’m willing to try stuff if anyone has any suggestions.

Thanks!

Have you tried installing the 0.27 firmware? Here is a link to the firmware

and their site:

https://www.gpd.hk/gpdp2maxfirmwaredriverbios