Anyone install arch, if so how's it going?

I want to try and get arch installed on the P2Max this weekend when I have a little time any tips or tricks for those that have been successful?

Thanks in advance!

I’m exclusively using Arch without any issues. I pretty much used my GPD Pocket 2 guide for the install.

Things to note (that differ with the guide):

  • rotation on the P2Max is normal, so no need to use the kernel option (fbcon=rotate:1) or Xorg 30-display.conf (mentioned in the guide)
  • for the touchscreen to work, you’ll need this DSDT override cpio image loaded before any other initrd images
  • you’ll probably want to make some changes to your trackpad config to improve scroll speed

Josh this is superb! Thank you so much!

I’ll be a little out of my element trying to use the fix here for the touchscreen - I’ve always run on old thinkpads which ave great support by default. I’ll try to pick up the pieces you’ve laid out so nicely, thank you!

1 Like

running through the usb and I keep getting sdhci register dumps - its not preventing me from doing anything but it is quite distracting

edit: i actually saved this webpage from before - Josh thanks again lol


Hey Josh -
any chance you could go into a little more detail on the DSDT override? I am going to try an piece it together but I am a little out of my element there. Thank you in advance for offering this help!

1 Like

Here is how I did it:

  1. Install acpica (pacman -S acpica)
  2. Download the dsl file from github and compile it (iasl -tc dsdt.dsl). This will create a dsdt.aml file we need in the next step
  3. Create a folder structure for creating a cpio image (mkdir -p kernel/firmware/acpi)
  4. cp dsdt.aml kernel/firmware/acpi/
  5. Now we can create the cpio image (find kernel | cpio -H newc --create > acpi_override)
  6. Copy the cpio image to your boot partition (cp acpi_override /boot)

After this you just need to configure your bootloader to use the fix. If you are using systemd-boot you can just add an initrd /acpi_override before initrd /initramfs-linux.img

For more information see

Note that for me the touchscreens stops working after waking up from sleep. I’m not sure if that’s related to my system, the fix itself or how I applied it.


@js33811 - Are you using grub, systemd-boot or refind?

I ended up with grub but could use systemd-boot as well. I got arch on here and am surprised how usable it is without the touchscreen

3 posts were split to a new topic: [LINUX] Fingerprint Scanner Not Working

@js33811 how did you get on with Grub? Myself and one other have a thread where we are struggling to load the cpio image and wonder if you had managed to load using a acpi_override in grub?

1 tried to load it when using grub and ended up frying my system… I started over and just used systemd-boot this time but honestly hadn’t messed with trying to fix the touchscreen again.

What Bios version are you using? If 0.23, did you manage to get the touchscreen to work with 0.23?
Thank you!

@minextu Are you using a pre v0.23 BIOS? Just recompiling (iasl -tc dsdt.dsl) the dsdt.dsl file in Peter’s repository will give you the equivalent of the pre-0.23 acpi_override file on his releases page.

There are a handful of legitimate DSDT changes from v0.22 -> v0.23 that need to be handled in order to prevent weird power issues. This is a link to the v0.23 CPIO image (which, if unpacked, will have the AML file you’re referencing).

@wondow @joshwiththegoodhair I was using 0.22 when I wrote this answer. Still haven’t upgraded to 0.23 since people seem to have problems with it.

Has anyone upgraded to the .24 bios to see if that fixes the touchscreen issues on arch? I just read the release notes from GPD saying it would fix the issue in Ubuntu so I am assuming that it will but I am admittedly lazy and am hoping the hive mind can help C:

I’m on Arch and 0.24 and can confirm the touchscreen issue is fixed from a hardware perspective - no hacks needed.

Thank you again josh! Two (likely silly) questions - 1 does the method found in the forum to flash bios without being inside windows work, 2 any negative consequences you can see?

I really appreciate your insight -my gratitude!

@js33811 - It definitely works and I have not seen any negative consequences. I’ve flashed bios from 0.20 incrementally to 0.23 using the usb method and it has worked perfectly every time. hope that helps. I’ve held off on 0.24 simply because the standby issues do not appear to have been resolved nor the fan improved and I have a hack for touchscreen in ubuntu so I’m reluctant to flash when I wont get much gain.

1 Like

I just followed the guide you posted and touchscreen is working. This forum is such a valuable resource - thanks to all of you smarter than me whom are able to provide resources!