GPD User Community Support Forum

Audio Pops / Ticking Sound Issue

User Minjun Seol
Has reported ticking sound issue.

He has a work-around or has partially resolved the issue by disabling the Realtek HD Audio driver.
Hopefully GPD will release an updated audio driver soon.

2 Likes

@Minjun

Can you please go into device manager and click realtek hd audio and properties and tell me the date of driver and the version number of the driver.

Also can you try use windows update driver? And see if this resolves the problem.
Thanks

Sorry for the late response.
The driver version is 6.0.1.8459.
I reinstalled window os, updated the audio driver and BIOS 2.2 but still have the same symptoms. So I am still not using the audio driver.

1 Like

Are you able to try the sound on another OS say ubuntu Mate 19.04 live usb?

I have never used ubuntu os. So that method is hard to try.

I could reproduce this issue on linux by enabling audio power management:
echo '1' > '/sys/module/snd_hda_intel/parameters/power_save'

So I suspect the Realtek driver under Windows is trying to enable power management too. You might be able to check if that’s the case by not letting the sound chip sleep (when playing audio it should go away and only come back a few seconds after stopping).

I haven’t looked into it that much, but this might help you if that’s the problem:

Basically you would need to disable power management by finding the options for it the registry. It might be in HKEY_CURRENT_USER\Software\Realtek\Audio\RtkNGUI64\PowerMgnt or HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\xxxx\yyyy\

1 Like

Thanks @minextu - This is very helpful.

There is no such folder where you said. Please explain it more easily.

@Minjun these are registry keys not folders.

When I get a moment I will try do a couple of screenshots to show you.

1 Like

Hi @Minjun

OK so I’ve checked the following Registry Keys in Regedit:
HKEY_CURRENT_USER\Software\Realtek\Audio\RtkNGUI64\PowerMgnt (This does not exist)
What does exist is HKEY_CURRENT_USER\Software\Realtek\Audio\RtkAudUService\General
as shown here: None of these relate to power management or “DelayTimer” variables.
see screenshot:

Also HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\xxxx\yyyy I think @minextu refers to is below: This also did not have any Power Management setting or “DelayTimer” interval setting to change see screenshot.

So I’m afraid I can’t assist much more with the solution @minextu suggests.

@Minjun Can I please ask you to do the following:

Windows Key + R key (Run Box)
type powercfg.cpl
Make a note of the Powerplan your on and let me know for example “Balanced” or “Power Saver”
I also want you to click on “Change Plan Settings” on whichever one it is
Then click “Change advanced power settings”
Then scroll down until you see “Processor power management”
Click on the + next to it
Click on the + next to Minimum processor state
Advise what the percentage number is if its as I expect 5% can you please alter it for testing purposes to 100%, restart the machine. Repeat the steps above to check that the “Minimum Processor State” has saved at 100% and then if it has do whatever it is you do to play audio and advise if the popping noise still occurs.

Thanks

1 Like

Sorry I don’t have Windows installed anymore, so I wasn’t able to check if the fix applies to the P2 Max.

You can also try installing the latest Realtek driver from here (choose latest 64bit version) and see if it changes anything.

1 Like

I’ve changed the minimum process state as you told me, but I’m still seeing the same symptoms. The driver version is also the latest. Is there a way to go back to the driver version, etc.?

1 Like

Hi, Is this audio pop happening through the 3.5mm headphone jack output or through the built in speakers?

Is there any short video you can do and upload here so we can see the issue?

Thanks