GPD User Community Support Forum

Blue Screen of Death (BSOD) Issue

This Topic is for users who are receiving Blue Screen of Death (BSOD) Issue.
Please provide the following:

  1. What you were doing on the device at the time the BSOD occured.
  2. Any technical error message
  3. A screenshot would be very helpful for us

Thanks

I played PES 2020 demo more than an hour with low settings, I didn’t get any BSOD issue. It may be because I fresh installed Windows 10? Maybe. BSOD is usually drivers conflict issues.

Thanks for feedback. Another chap has updated the firmware and done fresh install but still getting BSOD. I’m not sure whether its just him but hes going to come on here tomorrow and put screenshots of the exact messages hes getting. He said hes getting about 4-5 different ones.

If he can share what he is exactly doing to get BSOD, I can try to do the same since I also reinstalled Windows 10

1 Like

Thanks. Hes messaged on facebook saying he will do tomorrow. Think theres a time difference.

1 Like

Hello everyone – I am the guy that started the BSOD conversation on the GPD Indiegogo.

This is what I’ve found:

  • The device, when I received it and turned it on, had some sort of fault while initially setting up, that caused a reboot.
  • Windows seemed to “recover” after this, but whenever I tried to install anything, it seemed to BSOD on me, random things.
  • I installed Steam and wanted to see how the laptop would work under a manageable gaming load. I installed Civ 6 and Kings Quest (2015 version).
  • Upon install and running (and after the device sat for a while), Civ 6 loaded just fine. I set most settings to low and loaded an existing savegame from Steam Cloud.
  • I couldn’t make it more than 1 turn without the game freezing and erroring out.
  • Once the PC got “hot” or under a signficant load, BSODs start happening, seemingly at random.

I then decided that perhaps my initial install/reboot issue might have corrupted things. I downloaded and reinstalled the firmware (see other post in that topic).

The device came back up and I then had a pleasant setup experience. Perhaps there was an error in the initial setup that corrupted things?

  • I then repeated my original test of Steam, Civ 6, etc. Same issues.
  • I then tried Kings Quest as perhaps this problem is unique to Civ 6. Same issues, except I couldn’t get to settings before the laptop crashed.
  • I let the device sit for 3 hours to cool down, and then Kings Quest started working… but after 5 minutes it crashed out again.

I thought perhaps there are some old drivers in the firmware. I installed the latest Intel drivers (3 of them, one for Video, one for Audio, and one for Bluetooth).

Issues still recur. I started thinking that there is either a cooling issue or a component (memory, cpu?) issue…

On the GPD forum someone mentioned memory errors, I decided to try testing the memory. I did the Windows MemTest and the PassMark MemTest86. Both indicated serious memory issues.

I now think this is most definitely a hardware issue… perhaps memory? This explains the randomness that I have BSODs and other errors.

I’m attaching my BSODs and in-progress MemTest86. I will continue to post my errors to this thread.

This is a true bummer, as my keyboard and trackpad are perfect. The guts inside, not so much.

2 Likes

I don’t know if it has anything to do with your problem (the issue DEFINITIVELY sounds memory related though), but I see in the last screenshot of memtest that it’s listing you RAM as “Samsung H9CCNNNBJTMLAR” but when I look up that part number, those are actually SK Hynix memory chips, not Samsung.

1 Like

Wow… How do you know? Could this then be bios or firmware related? Perhaps some of the memory was swapped at hardware build and bios not updated to match?

I’m not sure what would cause the manufacturer name to not match the part number. All I did was Google the H9CCNNNBJTMLAR (trying to see if those modules had known issues, didnt find anything though) and the first site was an Intel page listing compatible memory modules for a CPU, and that part number and all part numbers starting with H9CC were listed as SK Hynix…

Thanks to both of you. This is really helpful. I think Jason you have a either a hardware ram failure or a firmware failure which is actually causing BSOD. Either way we have something real to show GPD and this is beneficial to you and others. Thanks again for contributing here as I think it’s really important we try help each other and put pressure on collectively for GPD to resolve ASAP.

Definitely. This could be caused by so many different things. Bad memory chips, bad solder job connecting the chips to the board, incorrect memory timings or voltage in the firmware, etc. It doesnt even technically have to be a ram issue because the memory tests all send data thru the CPU and cache as well so the problem could be there as well, and again could be hardware or firmware related. I’d guess it’s hardware related though, as the firmware settings “should” be identical on all units.

1 Like

I agree. Could be a bad solder joint. Personally I’ve never been a fan of Hynix RAM but that was DDR2 SO-DIMMs a long whilst back. Maybe they got better but I threw many away from laptops when I had repair business.

1 Like

Could it be that Samsung licensed the RAM, so it is Samsung branded but made by someone else? Might be interesting to run this test on a laptop that doesn’t exhibit these issues.

Everyone – Great news!

The bios update GPD uploaded in their comments section seems like it might actually do the trick. Here is the link…

Going to validate with more testing tomorrow, but I just played Civ 6 for 45 minutes with no crashes. Cautious optimism!

Link: http://www.gpd.hk/filedownload/28135

1 Like

Glad to hear the bios update may have fixed it! Glad I was wrong about it being hardware. But WOW, I just figured out, that with that bios update file they just released, its possible to have FULL control of EVERYTHING possible in the bios!! The file can be edited, basically god mode for the bios :smile: I don’t want to post how to do it here yet, as we don’t need people editing and flashing bios images and then screaming to GPD that its broken lol. Maybe in a month or so after the release window has calmed down. I do wish there was an original bios file to look at though so I could compare what they changed in this new file to fix those issues… Maybe when I get mine I’ll see if I can dump the original bios.

1 Like

I ran memory test yesterday, it passed the test.

1 Like

Thanks so to confirm you were having memory failure issues as well as sticky key issue and the new bios update GPD released has resolved the memory failure issues? Is this a good summary friend?

I am having only sticky keyboard issue, and terrible trackpad issue (left click) for now.

1 Like

I did not update the bios.

1 Like