GPD User Community Support Forum

Can't Turn Off Tap-to-Click (Windows 10)

Apparently if the touch-pad hardware vendor doesn’t provide the ability to turn off tap-to-click, there is no way to disable it. This is annoying the heck out of me. Its always the first change I make on a new laptop. Has anybody figured out a way to do this on the P2 Max?

2 Likes

Hi @Sepiternus,

I think the issue is that Windows is seeing the device as a Mouse rather than a touchpad.
I’m unsure as to why.

1 Like

I tried to find the device manufacturer for the Touchpad using the Device ID mentioned in the Device Manager, but it was in vain. So I have requested in IGG to mention the Manufacturer and Make of the Touchpad and asked them to provide the device driver specific to the Touchpad so that Windows 10 precision Touchpad controls can be modified in order to disable the Tap-To-Touch function.

But at the moment you can try to decrease the touch sensitivity if you would like to and see if that helps as a workaround.

Go to Windows Settings > Devices > Touchpad (You can even search for Touchpad setting using Windows search) and make Touchpad sensitivity to Low Sensitivity.

1 Like

Reply from GPD HK on IGG: It is no driver, it is the standard hid mouse device and Microsoft has its own driver.

This pretty much does not solve the issue at the moment. I have replied to them asking for the manufacturers name such that we our-self can try to search on the internet for an official driver which could possible enable the Microsoft Precision Touchpad Controls.

3 Likes

Had the same issue, couldn’t find the manufacturer, and the usb device id’s don’t reveal anything useful and gpd said you don’t need to know via IGG (i still want to know.)

1 Like