GDP XP flash update failure!

Hello everyone, I have just bought a GDP XP which was on firmware XP_V 1.40_2021127 the latest on the website was XP v141 en 202202160753 IMG which I downloaded and tried to flash, as I was getting graphical issues with some games and a couple of emulators were running very slow.

But I got an error message during the flash pop up “Failed to get PMT info”. The GPD XP won’t boot or turn on and I have tried reconnecting and it fails to flash with the same message constantly coming up.

Im gutted it’s a great device overall but it a brick at present, please can someone help or offer some advice on how I recover this device.

Many thanks for any help with this expensive dead device.


Also forgot to say, that searching the web some solutions say put it in download mode, not firmware upgrade to fix the error, Ive not done it but thought it worth asking if this would work.

I’m happy to reset the device and start again if someone could tell me how to resent and get it at least going again.

Many thanks.

OK so unfortunately little help with this, but I did flash in download mode and it at least brought the device back to life and has worked fine since. Not tried everything but it seems ok since the update via download rather than update.

I hope it helps others in similar predicament.