GPD Win Max 2019 Unlocked BIOS Ver 1.11 because no other file host is reliable long-term (except Github; we will not talk about that)


  • This BIOS version is outdated.
  • This BIOS is only for the 2019 devices with i5-1035G7 or equivalent

By downloading and flashing this unlocked BIOS, you acknowledge the following:

  • Incorrect settings may cause permanent damage to your data or your device.
  • Any damage caused by incorrect settings inside the unlocked BIOS is not covered under warranty by GPD.

Thank you for this- I still have my original Win Max. Do you know where we can download newer BIOS files? Is Windows required to flash them?

you can get the newest bios (version 1.3 last time I checked) on the HongKong GPD support page. A quick google should be able to lead you there.
This is also why I didn’t upload it here, since you can still get that.

I got this version from GPD Discord back when it existed, and from a mod called “YYang”. I was trying to disable hyperthreading because idk. It’s probably not the last version to be publicly available, since I obtained this device basically at launch. Before the 2021 refresh at least.

I tried to talk to the customer support (over Wechat and in Mandarin) but they do not seem to have a single idea what I am talking about.

Oh yes. the support. After a while of using this unlocked BIOS (for basically like 2/3 years) I started to notice problems, such as the screen not being able to turn back on if you close and open the lid at times. The intense backlight flickering is also related.

Oh yes. And then I noticed that the USB port will not work with CERTAIN USB devices, such as ones powered by Realtek 9210B. This one is so specific. and something else that basically do the same job, such as the JMS583, will be able to function completely fine. This is also regardless of what cable or USB speed, or even port that I use.

So I tried flashing the new 1.13 BIOS, but it won’t flash because it reports that the old BIOS have an “incorrect size”. Even the unlock BIOS reports an “incorrect bios size”, so something is up. I called support, mailed in the device to have them flash it via hardware.

I don’t think it’s the unlocked bios, since I can’t even re-flash the unlocked bios with/from the unlocked bios. I haven’t tried after, though, as I neither have a need nor actual will (why downgrade to potentially buggy bios when the new one satisfy 99% of the need)