GPD User Community Support Forum

How to enable screen orientation / rotate screen using hotkeys

Other laptops I’ve used have provided screen rotation via Ctrl + Alt + the arrow keys. That doesn’t seem to work on the P2 Max.

I’m currently using a free app called Screen Rotate from https://www.microsoft.com/en-us/p/screen-rotate/9nblggh3zd5h?activetab=pivot:overviewtab When running, it does allow for keyboard shortcuts. Ctrl + Alt + A for example, rotates counter-clockwise. See the settings in the program for full details.

Have you found a built-in keyboard shortcut that works, or a simpler solution? Please share if so.

Hi @FortressP2Maximus,
Shortcut to rotate the screen comes from Intel HD Graphics Control Panel. I know it because it matches the shortcuts in IntelliJ IDEA so on every device I have to disable this function (I saw a lot of annoyance caused by them in many places and experienced it myself :slight_smile: ). As I saw in new Intel machines they install Windows Store app called Intel Graphics Control Panel. Looks for me that they totally switched to it with 8th gen but saw both of the mentioned apps in 7th gen laptop (Windows Store and desktop one). On that 7th gen device the Windows Store app after first launch asked if it can remove the desktop version of it. I cannot check if in Windows Store version app the shortcuts are disabled or not exisisting at all since I don’t have the device anymore. Also I haven’t read about it anywhere; these were anly my observations so maybe there is some more information in the web.
The GPD P2 Max afair don’t have left alt (I don’t remember if the right alt+gr is a secondary and can trigger shortcut) so it is another problem but if the option in the app exists You can remap easily.
I hope that this comment was in some kind helpful to You :slight_smile:

2 Likes

Okay so I had an opportunity and tested it. I found out that there are two apps in the Windows Store: Intel Graphics Control Panel (mentioned earlier) and Intel Graphics Command Center (starting with 6th gen).
In first one (clone of desktop app) the hotkeys are gone but in the second one they are available - disabled with general switch and mapped with alt usage. I’ve tested and rotating with right alt works so no remapping is needed.
I’m providing screenshots of both apps with this post. FIrst one is Command Center.
Hope that solves Your problem :slight_smile:

2 Likes

This is really helpful @SomberBanana
Thanks very much.

Please can you retest this @FortressP2Maximus

Thanks

1 Like

As you said @SomberBanana in the Command Center app, checking the switch for Use System Hotkeys was all it took to restore the familiar functionality. Good find!

2 Likes