GPD User Community Support Forum

How to reinstall from P2-MAX-OS file

Hi

New member here, my device arrived Friday night. The installation of Win10 was a nightmare, frequent Memory_Management blue screens. Eventually I got an installation, but OS is not stable. So I tried to recovery from the recovery partition, that was no better.

So first port of call, was try to install of a clean Win10 USB loader, where not surprisingly I am getting IRQ and other errors, probably due to lack of correct drivers. Now I am trying to use the provided P2-MAX-OS-RS6-20190703 file.

But I have no idea how to get this onto a USB stick, and then onto the device.

Can anyone provide some pointers please? Much appreciated.

Thanks

CB

1 Like

What BIOS version are you on? There was a batch that had a lot of memory issues that were fixed by updating to 0.21 (at least).
Probably it’s better to run MemTest86 from a USB drive. If the memory is faulty – the device will have to be exchanged. But if your BIOS version is lower than 0.21 – update BIOS first.
Reinstalling windows won’t solve the issue.

I had upgraded to 0.24. I am currently running memtest just now. Waiting to get through all of the passes.

1 Like

@CEEBEE I would agree anything from bios 0.21 resolved these memory issues.

Thanks, I have finished running the memtest - no issue occurred. So unless there is a problem with the SSD, I am back to my original question - how can I get the RS6 file onto a USB so I can reinstall the recovery partition, or otherwise install from clean Win10 media.

Any help would be gratefully received - as I originally mentioned, the initial installation did not go at all well.

@CEEBEE

My understanding is

  1. Format the usb to NTFS
  2. Extract the compressed file to the root of the usb
  3. Spam Fn + 7 (f7)
    4 choose boot from usb partition

Should do everything else itself.

The other option is using windows create media tool and installing fresh then just using drivers.

I believe both options work.

I have tried the second option (creating new media) - it repeatedly fails on one of two issues (IRQ NOT EQUAL; or 0x8007025D). (It might be I need help on which drivers to select during the installation)

Let me try the first idea - thanks.

Colin

OK. So I have copied onto the USB drive. The USB drive needs renamed WINPE for the Main.cmd to work. It gets through copying data onto the newly created partitions, and then runs DSIM (Apply Image) and then Blue Screens with a stop code MEMORY_MANAGEMENT

Any ideas?

Anyone any ideas here?

Anyone able to get me a DD of the recovery partition?

Anyone willing to personally help me. I cannot install windows from the GPD provided recovery files, having tried to slipstream drivers into the boot image, and install image, I still get memory management BSOD.

Guess I have to return the device under warranty, as not fit for purpose.

@CEEBEE any reason you want to particularly install the OS provided by GPD? I suggest you to perform a clean installation of the OS, by downloading the installation media from Microsoft directly. You can find the instruction here below, and follow the instruction from the section where it says “How to Get Installation Media and Do a Clean Install of Windows 10”.
Before doing that I suggest you to upgrade your BIOS to 0.24 which seems to be more stable. Be careful while upgrading to BIOS and follow the instructions carefully. DO NOT TURN OFF THE SYSTEM until the entire process completes successfully. I suggest you to walk away from notebook for 10 - 15 minutes at-least, if you are impatient.
I am assuming that once you get the USB installation drive ready, you know to boot into it from BIOS. After you install the windows download the driver package from GPD. You will find unrecognized devices in the device manager, you can right click in those devices and update the device drivers by using the downloaded package. You may need to install only Goodix driver for Touch Screen, Focaltech fingerprint reader driver.
And don’t worry about the Windows activation, it will happen automatically after installation.

Thanks for the response.

I am on BIOS 0.24. I have tried to boot from clean Windows 10 media, I get a BSOD, IRQL-LESS-THAN (been a while since I had to deal with that) - so I never get the opportunity to install/update drivers post installation. I know how to boot from USB: create new USB drives; slipstream drivers (provided by GPD) into the installation; and hence if you where me you might understand my frustration.

However, I am happy to try again; perseverance is a virtue. Let me try again.

Ok. So that Has not worked. I have also tried to install Ubuntu 19 directly onto the device, the installer crashed.

If I was some amateur , I would put this down to me. But having been a unix admin for 20 + years, and lived with gentoo and Ubuntu for 15 and 10 respectively.

Unless anyone had to do anything special to install Ubuntu, this device is not fit for purpose,

Help anyone, I have lost patience now.

It really does sound like you’ve got a bad unit.