GPD User Community Support Forum

Memory diagnostic hardware damaged error / memtest86 failures

Hi,

If you have tested the memory using the Windows Memory Diagnostic and it has advised hardware damaged, please download Memtest86 Free Version from here https://www.memtest86.com/download.htm

Please run this Memtest which is the leading RAM memory tester.

Let me know if this passes or not. I think this is a false flag. ie. I believe Windows Memory Diagnostic is misreporting the issue and I think if you run Memtest86 you will see that it passes fine.

If you have failures with Memtest86, then please reply on this thread.

I ran MemTest86 v8.2. More than 2000 errors occurred at TEST 5,TEST 6.

1 Like

Can you please post a screenshot here.
Also do you get any other errors or bsod issue?
Thanks.

MemTest could not be completed due to too many errors

2 Likes

Thanks we will feed this to GPD and come back to you ASAP.

Are you in contact with them? I haven’t had any direct conversation with them at all.

1 Like

I haven’t had a reply currently but I have previously been in contact with them on email before the issues started. I’m hoping that Monday will be business as usual and GPD will work with us. I will do my best to push for this support forum to be the mechanism by which we can diagnose issues and resolve them quickly either by pointing user to specific instructions eg reinstall or firmware upgrade or in actual cases of hardware failures get some kind of RMA process in place to facilitate quick resolution of these problems. I believe GPD will work with us for sure.

Nothero please could you try running a game in Steam and advise if your experiencing similar issues to what Jason is experiencing in the BSOD thread. The reason we are asking is We are trying to understand if the ram issue is the cause of the bsod issue being experienced by a few people. Thanks

I run Memtest86 on all of my systems when I set them up. Great for finding problems including misseated DIMMs, etc.

1 Like

I ran memtest and mine completed (after several hours). Found over 8,000 errors. See attached…

1 Like

Everyone – Great news!

The bios update GPD uploaded in their comments section seems like it might actually do the trick. Here is the link…

Going to validate with more testing tomorrow, but I just played Civ 6 for 45 minutes with no crashes. Cautious optimism!

Link: http://www.gpd.hk/filedownload/28135

1 Like

Excellent news. Please keep us updated.

Hi jasonchalk.
Will you run MemTest86 again and tell me the results?
please.
I can’t test now.

I think Jason said he was going to retest memory today after he had tested it for 24 hours. Can’t blame him for wanting to actually use his new computer :wink:

I went home and updated BIOS,and ran MemTest86 again.Although the number of errors has decreased, more than 1000 have occurred. The hardware problem is not solved.

1 Like

Do you have any other symptoms blue screen of death? How is laptop performing? Any screenshot following bios update for us to look at please? It could just be a timing issue with ram chips which may not be causing any noticeable degradation. Please try to explain as much as possible here so the community understands what the issue is. Thanks

Yeah – I will run the memtest overnight tonight and post results in the morning. Right now I am using the device and functionally it is exactly what I hoped it to be. Speedy, stable, and portable!

1 Like

This is excellent news. So glad that this bios update has resolved all your problems. Thanks very much for your updates.

As promised, I ran the Memtest86 last night again after the bios update… I went from 8,000+ errors to… drumroll please… 0 ISSUES! Screen capture for proof, before and after. One thing that is interesting is that the listed memory changed. Perhaps that is what the BIOS did. Maybe they had a memory supplier switch and pushed an older version of bios? Just a guess…

2 Likes

Made up for you @jasonchalk Thanks very much for promising to post the progress here.
Excellent news.

Enjoy your GPD P2 Max my friend.

Moving this issue to resolved as proven by @jasonchalk

Thanks