GPD User Community Support Forum

Other Linux OS

Hi, just setting this thread up for any discussion on other Linux operating systems tried by users. I’ve heard that Ubuntu and Fedora work out of the box with hardly any issues except touchscreen which we know about.

1 Like

Have anybody tried if Arch worked on p2max?

1 Like

Don’t have mine yet, but Parrot OS 4.7 is using kernel 5.2 so it should it should be 100% working with the P2 Max.
https://download.parrotsec.org/parrot/iso/testing/

2 Likes

Liliputing has tested PopOS, Ubuntu, Chromium on this link

And The Phawx has tested Fedora on this link

Not seen a specific arch one sorry.

No problem! I will try running Arch after I got my one. Thanks

1 Like

I’m using Arch on mine and it’s working perfectly other than the fact that the touchpad scroll speed is slow.

1 Like

Sounds great! Do you mean two finger scroll speed is slow? I remember there is a setting of xf86-input-synaptics which is named EmulateTwoFingerMinZ/W. Maybe you could try to adjust the value to solve the problem?

This below is the introduction of Touchpad Synaptics from Arch wiki
https://wiki.archlinux.org/index.php/Touchpad_Synaptics

1 Like

@jasper - The touchpad isn’t from Synaptics, so we can’t use that xf86 driver. The brand is Hailuck and appears to be the same (or similar) to the touchpad used on the Pine64.

1 Like

@joshwiththegoodhair Thanks for your reply and the information. Cause my machine is still waiting for delivery so I can’t test it by my own yet.
Based on the information you gave to me, I emailed to Hailuck, asking for the Linux touchpad driver for this specific machine and i am still waiting for the reply.
Any new progress I will post here to let us discuss.
Thanks

1 Like

Thanks @Jasper. This is great work thanks.

1 Like

@admin Thanks for giving us a place to help each other. Thanks :smile:

1 Like

I’m mostly using mine for work/conferences, so I’ve tried out ParrotOS and Kali so far.

ParrotOS ran into the same issues it did when I tried installing it on a Razer Stealth: Zero recognition of the ethernet/wifi hardware or drivers. No issues running it live from USB, but when I go to install it directly on the device, it’s as though the installer just can’t recognize the network hardware.

Kali, however, appears to work right out of the box (with the catch that you have to manually enable bluetooth to use it, but that’s not a big hitch).

The only catches I’ve run into so far have been the touchpad being… well… a little touchy (sometimes a little difficult to get a click to register, but I don’t know if that’s the Linux or just the touchpad), and my bluetooth mouse can be jittery and slow. Any of y’all seen that with other distros?

@Itaquino The “jittery” bluetooth mouse problem is probably because you are using kernel < 5.3 and a bluetooth LE mouse and you’ll understand everything in the following thread. It has nothing to do with GPD.

Test the fix quickly (this won’t persist):
https://bbs.archlinux.org/viewtopic.php?pid=1856580#p1856580

Implement a persistent fix:
https://bbs.archlinux.org/viewtopic.php?pid=1860951#p1860951