GPD User Community Support Forum

P2 Max: Cannot completely disable the touchpad when using a mouse

I bought a bluetooth mouse so that I could uncheck “Leave touchpad on when a mouse is connected” in Settings, because my palm kept hitting the touchpad while typing.

This worked, and I can no longer use the touchpad at all while the mouse is connected.

HOWEVER, the touchpad is not completely disabled.

  1. If you are touching the touchpad, you cannot type.
  2. If you hold a key, touch the touchpad while holding that key, THEN release the key, that key will continue repeating. It doesn’t sound like much, but I’m getting this a lot while typing normally. The hardware definition of ‘hold’ is much shorter than a human’s.

I’m really hoping this is fixable in firmware.

1 Like

I guess the firmware of the touch-pad and keyboard are tied up together.