GPD User Community Support Forum

P2 Max stuck during BIOS upgrade

Hi Everyone,
I am attempting to update the BIOS on my P2 Max. Initially I tried to apply the latest BIOS via the " P2_P2MAX_1909_20200623-User-EN" download. That BIOS would not update, listing that it was not compatible. I then attempted to update to v0.29. The update started OK, but then it got stuck at 61% writing ROM (I don’t remember exactly what it said). It sat for 20 mins at 61%, then I attempted to move the CMD window. It went behind another explorer window and then the trackpad stopped working. Now the laptop is still on but totally stuck, no keyboard, and the clock hasn’t changed in hours, meaning that Windows it totally locked up. What should I do? I am hesitant to force a reboot but it seems there are no other options.

ps. Unfortunately I didn’t check the BIOS version before the update. Stupid, I know!

Problem solved! Ended up forcing a reboot by holding the power button and luckily it fired back up to the new 0.29 bios!

1 Like