GPD User Community Support Forum

Touchscreen stopped working after 0.21 bios upgrade

After upgraded P2MAX.0.21-afu (BIOS) firmware, the touch screen won’t work :frowning: !
Please help!

1 Like

Thanks @Wicky

I’m unable to recreate this issue. I have upgraded to 0.21 bios and my touchscreen is perfect?

Possible ideas:

  1. Are you able to run a Windows Live PE from usb and see if touchscreen is working?

  2. Have you tried updating drivers in Device Manager? (Before doing this please make sure you have downloaded official drivers from GPD first or have access to another machine connected to internet)

  3. Are you able to do a fresh install of Windows 10 Home?

I tried 1. but the Windows Live PE iso that I’ve got does not have touch driver such that I cannot test it out by this way.

I have tried 2., too but still no luck to get the touch screen work.

  1. I do not have a Windows 10 CD to do a fresh install

Any other advise, thanks in advance.

1 Like

@Wicky

You can do this

  1. Create a Bootable USB flash drive by using Microsoft Media Creation Tool see here: https://www.tenforums.com/tutorials/2376-create-bootable-usb-flash-drive-install-windows-10-a.html#option1
    I can confirm that I’ve done this and it created a USB media bootable with Windows 10 Home on it.

  2. Then use the VBS script i provided here to extract you Windows 10 Home OEM product key.
    I’d also just to be sure use the GPD Bios Check Tool to check that the VBS script OEM key is the same.

see this post here: GPD P2 Max - [WINDOWS] Two ways to get Windows 10 Home OEM Product Key

@Wicky - please advise if you have tried the above and whether it was successful.
Thanks.

@Wicky - We had another user report the same issue and he followed these steps by @aravind and the problem is now resolved.

Aravind Chandrasekaran
Please try to install the goodix touch screen driver and the FocalTech fingerprint reader drivers from the drivers downloaded from the GPD website.

I will mark this resolved pending retest - if this doesnt work please come back here and let us know.

@admin, I checked both of the mentioned drivers are already installed but my touch screen still not working. So, please don’t mark this as resolved, since it actually no resolved yet, thanks!

1 Like

Ok, Can you at least uninstall the touchscreen driver restart the machine and then install the driver manually?

Hi, this morning I attempt to remove all the partitions then re-install the windows… finally I can get the touch screen back to work, thanks for your support !

Btw, when I re-install windows it did not ask me the key, is that normal?

2 Likes

@Wicky Yes Microsoft registers your device id and key on their servers. So when you connect to the internet the activation happens automatically. In most of the cases the key would not be asked during installation, if Microsoft already finds your device id tagged to a key on their servers.

1 Like

I’m so happy you tried this @Wicky
Are you happy now for me to resolve?
I’ll move to resolved pending retest and leave it in there 24 hours before moving to resolved unless I hear back from you.

Thanks again @Wicky for being part of this community.

1 Like

Hi, Yes I am happy the issue got resolved, thanks.

1 Like