GPD User Community Support Forum

[HACKINTOSH] Help

Anyone else has tried installing hackintosh into their P2 Max?

I know it can be done, as shown in this video: https://www.youtube.com/watch?v=i5ZxykBSki8

But I can’t even get pass the installation screen (kernel panic)

Using this EFI: https://github.com/hellodeibu/gpd-pocket2-hackintosh

anyone else has any luck?

1 Like

Thanks for your contribution here @edward-s

Unfortunately I have not yet received my device so I’m unable to assist here.

I hope someone in this community will help you. Thanks again.

untested by me; from user azkali:

  1. prepare a MacOS (journalised) formated usb key with a partition smaller than 32gb
  2. download unibeast from tonymacx86
  3. download Mojave from the app store
  4. close the Mojave installer
  5. launch unibeast, it should detect the installer for Mojave and the usb drive you previously formated, click next to all, choosing UEFI for bios setting, leave the rest empty
  6. boot from the usb drive on the P2 Max
  7. create a MacOS journalised partition from the live usb on your main drive (using disk utility, be careful not to erase your whole drive )
  8. Install Mojave on the newly created partition
  9. wait for it to install, it will reboot so I recommend you should set your usb drive as first boot option in bios setting
  10. when Mojave is Installed and is booted mount the EFI partition on your main drive and the efi partition from the usb drive, then copy paste your EFI folder from the usb efi partition to the drive efi partition ( use clover configurator to easily mount efi partitions or search for the command line to use if you’re comfortable enough )
  11. modify you config.plist as needed and Install needed kexts for the system to properly use all functionality ( I use hackintool )
1 Like

The Pocket 2 EFI won’t work for the P2 Max, they’re quite different machines. There is a working EFI folder here for the P2 Max - https://www.insanelymac.com/forum/topic/340330-clover-efi-for-gpd-p2-max-with-m3-8100y/?tab=comments#comment-2690225

You have to make a free account with Insanely Mac to download the link. HOWEVER, this EFI will only work on BIOS version 0.22 I think (or earlier), maybe even 0.21. It was working great for me with Mojave until I stupidly updated the BIOS to 0.24 and now no longer works. I have reached out to the original creator of the EFI to see if he is updating it for the new BIOS, but no response alas! Everything was working apart from WiFi (which is Intel and will never be supported) and touchscreen. I’m hoping others are working on it and we’ll have a tiny touch screen MacBook Mini soon!

1 Like

Hi all,

This may be of interest to some of you following this thread:

I’ve managed to get Catalina working on my p2max, everything is fine except for an issue with the DSDT.aml file.
Clover won’t start the system if I use DSDT.aml so I had to choose BIOS.aml option instead.
The downside is that I can’t get battery management.
Does anyone know how to deal with it.
I’d really appreciate any help.
Thx.

1 Like

@Space can you assist here? I know you got battery management working on your own hackintosh setup?

Thanks

Hey guys, sorry for the late reply. @juniorlemos in your "patched’ folder change the file DSDT_2.aml file to DSDT.aml and remove the original DSDT.aml file. You and I have the 2nd batch which requires the optional DSDT. Good luck!!

2 Likes

Thanks for this @space. Really appreciated. Hopefully @juniorlemos can retest.

I thank you guys anyway, but I’ve already tried it with both the DSDT files inside @Space EFI Folder, but unfortunately it doesn’t work for me.
Whenever I try to boot the system using one of these DSDT files, the progress bar goes only half way then restarts. I’ve tried it using “-v debug=0x100 keepsyms=1” arguments, then I get the message in the attached picture.
I’ve also tried to patch it myself, by extracting my own machine’s DSDT files and using iasl and MaciASL. Although I’ve successfully managed to compile the files and get the system to boot using them, I still can’t get battery status.
But I won’t give up, maybe I’ll start from scratch and see what happens.
Thx

@Space do you have the battery patch code for our P2 Max, that way I could patch it myself using MaciASL. Thx

Hey so sorry. I forgot that the final EFI is now at https://github.com/Azkali/GPD-P2-MAX-Hackintosh. This is the latest working EFI with many fixes from my original. Working on 0.24 & 0.25 FW. Good luck!

2 Likes

Thanks very much for this! @Space

Thanks @Space but since the first release of the Azkali’s EFI folder, none of the dsdt files seem to work on my p2max, could it be due to the ssd I’ve swapped. My P2max has a 2TB Hikvision ssd https://www.aliexpress.com/item/HIKVISION-SSD-M2-2TB-256GB-M-2-NVMe-PCIe-C2000-Pro-3500mb-s-Fast-Solid-State/4000074039231.html?spm=a2g0s.9042311.0.0.402db90aco2btG
Would the dsdt need a new patch to work on my device?

I’m having a problem booting the Catalina installer on my P2 Max with BIOS version 0.24.
I created the Catalina USB installation media using the createinstallmedia command on a real Mac with the official Catalina installer from the App Store.

I tried using Azkali’s EFI folder (from https://github.com/Azkali/GPD-P2-MAX-Hackintosh), but I am getting this KP -

Using the 2nd DSDT file doesn’t seem to make a difference and boot results in a similar KP.

I haven’t managed to get the Mojave installer to boot, either. Other EFI folders (including the one I downloaded from the GPD website) produce different errors and I’m not able to reach the installer.

Any ideas?

@juniorlemos
@Itayst

Hey guys - thought I’d chime in here as I’ve had the same issues as described.

I’ve currently got everything running on firmware 0.24 using the EFI folder linked here. Attachment name is GPD P2 MAX 0.24_v1.1.zip.

This is a different configuration to the one supplied by Space and doesn’t require the use of DSDT patching to bring complete support (including battery management).

I also enabled USB Injection, USB Ownership and Inject Clock to resolve sleep issues when you have USB devices connected (such as a Wifi dongle).

There is still a little weirdness around lid close detection however manual sleep via the menu bar seems to be perfect.

Hope that helps!

2 Likes

Further to my last message I would recommend adding the CPUFriend kext otherwise the CPU will have a minimum clock of 1.2 GHz causing unnecessary battery loss.

For reference Windows will step down to ~0.5 GHz at idle.

Here is an easy one key CPUFriend configurator. Run this and set your minimum clock 500Mhz then copy the files to your EFI Clover folder. I’ve also disabled CFG Lock on my BIOS but I’m not sure if that’s required.

Either way this yields similar battery life to Windows now at around 5 hours for regular usage.

On another note I’ve discovered 4K output via USB-C and Mini HDMI is broken on all available configurations. I’ve tried a few well known fixes (stolenmem increase, custom resolutions via EDID override, activate monitor on wake) but haven’t managed to crack this yet. Will post back here if I discover anything.

1 Like

@tonyorlando

Thank you buddy… I’ve managed to install macOS and got basically everything I wanted sorted out. That’s awesome, much appreciated!

Hi @tonyorlando, I appreciate your help, but the provided link isn’t working anymore.
Could you please upload your EFI folder and send me the link.
Thank you.

@juniorlemos

You’ll need to sign up on that site in order to download the file otherwise the attachment will 404.

Let me know if it doesn’t though and I’ll upload my EFI folder.