GPD User Community Support Forum

UEFI EFI Shell: Cannot read from file - 800000000000001F

I encountered an issue with Flashing the bios from usb pen.
It turned out to actually not be related to the method of flashing with usb but rather than during the process I had dumped some files in the root of the factory formatted DATA partition.
One of them files was startup.nsh script and this was causing UEFI EFI Shell: Cannot read from file - 800000000000001F every time i tried to boot into UEFI EFI Shell, regardless of whether I had the USB drive in or out of the machine.

Thanks to @joshwiththegoodhair for resolving this problem. I have kept all the posts and moved them into this thread incase it is useful for someone else in the future.

@PeterCxy - This method doesn’t appear to work for Bios version 0.22
I get the following after the "Press Esc in x seconds to skip startup.nsh, any other key to continue.
I let the timer countdown
Shell: Cannot read from file - 800000000000001F
Do you have any ideas/suggestions as to why?
Thanks.

I can confirm it works totally fine with 0.22. I just flashed 0.22 yesterday and everything went totally fine. Please make sure your files are not corrupted when copied to a USB stick.

1 Like

Thanks I will retest with different files and different USB.

@PeterCxy - Same issue for me.
Can you confirm if you did yours with 3 files or whether you also included the Afu64.nsh
(4 files)

Thanks

@PeterCxy - re-downloaded your file after deleting all files and starting over.
Tried two different usbs formatted them fresh FAT 32.
then copied the files over as above.
I should add for the sake of completion that I re-downloaded the GPD Bios 22 file and re-extracted the 0.22 bin and copied it to usb.

get: Shell: Cannot read from file - 800000000000001F
I also tried including your Afu64.nsh (4 files on usb) and modified this file accordingly but the same issue
Shell: Cannot read from file - 800000000000001F

Its now the same whether I use 21 or 22 bin file.

I am going to try a different O/S to make the USB now as I’m not sure if Windows is the issue.
Will test making the usb on Ubuntu Mate Live 19.04

I did with only 3 files. I checked again and my BIOS version is really at 0.22. No problem at all.

before anything else, let’s confirm the sha1 checksum of that bin file.

36a68dd5da3eabe9993d28d0099090413defd3e4 P2MAX.0.22.bin

Tried creating the USB fresh in Ubuntu Mate 19.04 live.
Using Unrar to extract @PeterCxy rar file and the GPD Bios Rar and p7zip-full installed to extract the .exe

Same issue
Cannot read from file
Tried two different USB drives and used Ubuntu Disks to format them
I used nano to create and edit startup.nsh from fresh

I suspect something in your other EFI system partitions have messed stuff up since your problem now happens with 0.21 or 0.22… Because that script actually scans all readable file systems from EFI Shell and finds the .bin file. If you know how to use EFI Shell you can try to flash manually and see if there is still the error.

1 Like

C:\Users\petem>certutil -hashfile F:\P2MAX.0.22.bin
SHA1 hash of F:\P2MAX.0.22.bin:
36a68dd5da3eabe9993d28d0099090413defd3e4
CertUtil: -hashfile command completed successfully.

C:\Users\petem>certutil -hashfile F:\afuefix64.efi
SHA1 hash of F:\afuefix64.efi:
7bb0868bcc05a42e93578049cd64937ba061d1af
CertUtil: -hashfile command completed successfully.

C:\Users\petem>certutil -hashfile F:\startup.nsh
SHA1 hash of F:\startup.nsh:
89f3058657f37841f0ef387b9ab9558bcee278e8
CertUtil: -hashfile command completed successfully.

Unfortunately I do not know how to use EFI Shell to flash manually.
I will research.
Thanks

Ok so I entered EFI Shell

FS4:

Did dir
Can see that the contents of the USB are there

I tried
afeufix64.efi P2MAX.0.22.bin /p /b /n /r /k
Not recognised as an internal or external command, operable program, or batch file

I also tried afeufix64 P2MAX.0.22.bin /p / b /n /r /k
Not recognised as an internal or external command, operable program, or batch file

No joy. I’m probably doing something wrong.
I also tried to execute startup.nsh the device rebooted and loaded windows but did not upgrade bios.

if it’s not corrupt file or things messed up due to files from other partitions, then I have no clue… I’m really on 0.22 and there’s no other way I could have flashed the BIOS because I don’t even have Windows anymore.

1 Like

I’m curious: @PeterCxy did You perform the update more than once using this method? Like 0.19 -> 0.21, 0.21 -> 0.22?

1 Like

I went 0.20 (this is what was shipped with my device) to 0.21 with this method.
I am now trying to go from 0.21 to 0.22 with the same method. (no joy)

1 Like

Thanks for your efforts anyway @PeterCxy - I haven’t changed partiitons or reinstalled the SSD or anything its literally as it came. I’ve been reluctant to change much because of the amount of updates coming from GPD.

Ok, how about Peter? Did he performed it more than once?

OK, So without any usb device present - I get the same error trying to boot uefi shell
after "Press Esc in x seconds to skip startup.nsh, any other key to continue,
“Cannot Read from File - 800000000000001F”

This did not do this previously. If USB wasnt present it simply entered into Shell >
(i think)

From what I’ve read about executing nsh scripts in Efi Shell this error usually occurs if the partition is ntfs and efi shell can read ntfs but struggles with permissions in executing. But for clarification both usbs are fat32 formatted.

I’m going to DD both usb flash drives now using Linux and reformat in Linux as fat
ok so did dd if=/dev/urandom of=/dev/sdb bs=1M count=1

then performed mkdosfs -F 32 -I /dev/sdb
then recopied the files above with verified hashes.

Same issue.
“Cannot Read from File - 800000000000001F”

Not sure what else I can do now as I’ve spent many hours wasted just trying to upgrade bios to version 0.22

Sorry for earlier not precisely addressed comments. I was writing quickly from the work.
Without any device I can confirm it goes to the shell after countdown. Adding the snapshot how it looks.

I’m not updating now to 0.22 - will wait some time. Damn what the hell happened? Can You create an archive consisting of the files that You put on thumb drive? Just to check. I know that without any medium connected when it goes this way it’s probably not the problem…still would do it. But mark the archive in some (best possible) way that no one would use it to flash.

Earlier question reason was that maybe the process does upgrade to newer version but it’s impact is that still something is going wrong and causes the error. When somebody does this process successfully twice then mostly it’s busted. So still I’m waiting for response from Peter. It’s good that You posted what You’ve done too, just added second comment to make sure that Peter knows I haven’t missclicked when replying and wrote to him.

1 Like