GPD User Community Support Forum

Update bios with ubuntu

it is great that some issues with ubuntu have been solved with the new bios, but how can i update the bios in ubuntu? I have tried free dos, efi shell, virtual box, wine, all without success. It is also not possible to extract the rom files from the exe file. How have the others solved this?

all the best,
Martin

1 Like

Hi @Martin,

I used this method How to Flash Bios from USB Pen (Without Windows) and have successfully upgraded the bios incrementally every time. My starting bios was 0.21, (The only one I skipped was 0.23) and I am running 0.24.

What issues are you experiencing?

I somehow missed this one, it works fine, thanks a lot!
best,
Martin

1 Like

No problem easy done. The forum isn’t the best at searching.

I am an Linux Ubuntu user. I must say that BIOS update is very dangerous. If your Windows decides to reboot for some reason while updating or the update fails, you will have a no working computer!!!

There is no way to recover BIOS by connecting a USB flash drive at boot, like in other BIOS.

GPD does not provide the full BIOS binary file if we wanted to flash the SPI flash memory on the board so we will never be able to recover it. Also, we can not flash it on board, since systems like the Embedded Controller are always active an running their own firmware from that SPI flash memory… also, unsoldering from the board is VERY HARD.
Since I understand, to flash BIOS there are tight procedures like first send specific commands to disable Embedded Controller and other systems that are always communicating with the SPI flash memory, so update BIOS is fatal if fails.

@casainho

This method may be safer for you.